1. Willkommen im Forum! Registriere dich, um eigene Beiträge zu schreiben.

Problem Deviation auf Devo 7e flashen

Dieses Thema im Forum "Deviation Firmware" wurde erstellt von hugohabicht, 21. Mai 2017.

  1. hugohabicht

    hugohabicht Walkerafan

    Beiträge:
    7
    Zustimmungen:
    0
    Hallo Fans,
    ich habe eine Devo 7e und habe mit dem Deviation Uploader versucht auf die Devo Deviation zu flashen. Das hat auch funktioniert. Als ich die Devo dann angemacht habe startete devention und alle Einstellungen waren zurückgesetzt. Als ich es nochmal probiert habe zu flashen dauerte es nur ein paar Sekunden und es kam die Meldung "Copy complete", wie beim ersten Mal. Beim anmachen startete wieder devention. Mit dem DfuSe tool funktionierte es von Anfang an nicht, da es die devo nicht erkannt hat. Was muss ich machen um deviation zu flashen und zu starten?
    Vielen Dank im voraus.
    hugohabicht
     
  2. linux

    linux Walkera Wahnsinniger

    Beiträge:
    5.081
    Zustimmungen:
    649
  3. Martinnw

    Martinnw Walkerafan

    Beiträge:
    24
    Zustimmungen:
    0
    Nach dem Flashen und USB formatieren kommt :
    Missing Modules
    CYRF6936

    Was mache ich falsch?
    Videos habe ich schon genug gesehen aber alles waren so wie ich geflasht habe.
     
  4. Corvette

    Corvette Chefdiplomkaotiker Mitarbeiter

    Beiträge:
    7.345
    Zustimmungen:
    5.918
    Ort:
    Heilbronn
    Homepage:
    Hast du den das Modul eingelötet?
     
  5. Martinnw

    Martinnw Walkerafan

    Beiträge:
    24
    Zustimmungen:
    0
    Nein. Die Devo ist wie aus der Schachtel.
     
  6. Martinnw

    Martinnw Walkerafan

    Beiträge:
    24
    Zustimmungen:
    0
    Ich habe die 4.01 geflasht und der Fehler ist weg. Ich bekomme aber keine Verbindung wie mit der WK2602.
    Man kann auch nur 2601 auswählen.
    Reini hab ich gemacht und auch die FixID gelöscht.
     
  7. KampfGurke

    KampfGurke Fairnesspilot

    Beiträge:
    2.487
    Zustimmungen:
    986
    Ort:
    57632
    Das ist das Originale Modul, braucht er nicht einlöten ^^
    Die Hardware.ini sollte auch richtig sein :unsure: wenn er die richtige Version geflasht hat!

    Sonst einfach mal versuchen mit dem Walkera DfuSe Tool zu flashen, wie steht alles in der Anleitung:
    Deviation - User Manual for DEVO 7E/10/12E
    unter Installation!

    In dem Thread findest du am Ende immer die "aktuellste" Version (Version ist 5.0.0 aber es sind die neuen Protokolle wie z.b. FrskyX integriert):
    Deviation v5.0.0 build with latest protocols

    Die Ordnerstruktur die du am ende auf den Sender Kopieren musst nimmst du wie vorher aus dem Normalen 5.0.0 Download:
    Deviation - Downloads - Deviation 5.0.0

    Und dann sollte das laufen ^^
     
    Theoretiker gefällt das.
  8. Martinnw

    Martinnw Walkerafan

    Beiträge:
    24
    Zustimmungen:
    0
    Danke für die Tips aber es klappt nicht.
    Den Wslkera Flasher bekomme ich nicht ans laufen. Nur den auf Java.
    4.01 ist drauf aber eine Verbindung zum WK2602 bleibt aus.
     
  9. KampfGurke

    KampfGurke Fairnesspilot

    Beiträge:
    2.487
    Zustimmungen:
    986
    Ort:
    57632
    Nicht ans laufen ist immer eine Fehlerbeschreibung mit der man nicht sehr viel anfangen kann ;)
    Du weißt das du für jedes der beiden Tools einen anderen Treiber brauchst? Dann wird auch die Devo richtig erkannt, ich Flashe z.b. nur mit dem Walkera Tool! Klappt bei der Devo 10 und der F4 mit eingebautem 4MB Flash wunderbar!

    Lad dir mal von hier den Installer für den/die Treiber:
    https://www.deviationtx.com/downloa...b-tool?download=1115:dfu-usbdrv-installer-1-1
    da wirst du am anfang gefragt ob du für den Deviation Uploader oder für das Walkera Tool den Treiber installieren möchtest!

    Ambesten erstmal den letzten Punkt wählen (remove all) und dann nimmst du mal den 2ten Punkt eben für das Walkera Tool und versuchst es dann nochmal :)
     
    Theoretiker gefällt das.
  10. Martinnw

    Martinnw Walkerafan

    Beiträge:
    24
    Zustimmungen:
    0
    Da hast du natürlich recht.

    Also mit dem Tool erst mal removed und dann Walkera neu eingespielt. Ich habe es mit ver. 2.31 und 3.0.5 versucht... die Anlage wird leider nicht erkannt.

    Zu den geht nicht Fehlern ...
    Also noch mal 5.0 geflasht und dann die Protokolle ersetzt. ( vielleicht ist das der Fehler.)
    „Protocol Mismash“ mit Zahlen dahinter.
     
  11. Martinnw

    Martinnw Walkerafan

    Beiträge:
    24
    Zustimmungen:
    0
    Um sicher zu gehen das es nicht am Windows liegt habe ich noch ein pc mit Win7 probiert. Alles installiert und neu gestartet.
    Nun ging der Walkera flasher ...
    letzte Protokolle geflasht dann das Fileset draus... Protokoll mismatch
     
  12. Martinnw

    Martinnw Walkerafan

    Beiträge:
    24
    Zustimmungen:
    0
    Also wieder 4.01 drauf... nur gebunden bekomme ch nichts mit dem WK2602.
     
  13. Martinnw

    Martinnw Walkerafan

    Beiträge:
    24
    Zustimmungen:
    0
    Kann es sein das ich am 4g6 noch was machen muss?
     
  14. KampfGurke

    KampfGurke Fairnesspilot

    Beiträge:
    2.487
    Zustimmungen:
    986
    Ort:
    57632
    Wie letzte Protokolle geflasht? Du musst normal nur die eine .dfu flashen also die:
    https://www.deviationtx.com/media/kunena/attachments/98/devo7e-2017-10-23.zip
    musst mal schauen ob du dort auch die richtige genommen hast!
    Paar Zeilen weiter oben in dem Thread im Deviation Forum steht nämlich auch nochmal Devo7e-256, die Version läuft bei dir nicht, die brauchst du wenn du deinen CPU ausgetauscht hättest! (Ultimate7e: Upgrade the Devo7e processor)

    Nach dem Flashen direkt in den USB Mode und dann nimmst du den Inhalt aus dem Zip file vom Normalen 5.0.0 release und kopierst alles auf die Funke bis auf die .dfu und die .zip dort drinnen!

    Dann muss das laufen wenn die Dateien die richtigen sind ! Zu dem Problem mit deinem Empfänger evtl mal im deviation Forum nachfragen da kann ich nichts zu beitragen sry
     
    Theoretiker gefällt das.
  15. Martinnw

    Martinnw Walkerafan

    Beiträge:
    24
    Zustimmungen:
    0
    Ja so habe ich es gemacht.
    Also mit Walhera Flash das File aus dem ZIP geflasht und den Ordner mit den Protocoldateien rein kopiert.
    Ich werde heute es schritt für schritt noch mal durchführen und genau schreiben welches file ich genommen habe.
     
  16. KampfGurke

    KampfGurke Fairnesspilot

    Beiträge:
    2.487
    Zustimmungen:
    986
    Ort:
    57632
    Aus der .zip muss alles auf den Sender nicht nur der Protokoll Ordner?! Alles bis auf die .dfu und die .zip aus dem Archiv nehmen und so wie es ist mit Ordner auf den Sender!
     
  17. Martinnw

    Martinnw Walkerafan

    Beiträge:
    24
    Zustimmungen:
    0
    Ja klar. Aber im ZIP aus dem Forum ist nur das DFÜ File und der Protocol Ordner.
    Der Rest ist wie du ja schon gesagt hast vom Ursprungs 5.0
     
  18. KampfGurke

    KampfGurke Fairnesspilot

    Beiträge:
    2.487
    Zustimmungen:
    986
    Ort:
    57632
    Achso ja klar :) ... Verdammt mir gehen langsam die Ideen aus :(
    Hast du eigentlich mal versucht mit einem anderen Empfänger zu binden? Das funktioniert oder?
     
  19. Martinnw

    Martinnw Walkerafan

    Beiträge:
    24
    Zustimmungen:
    0
    Ich habe nur noch mal den gleiche aus einem CP 4g6 und der ging auch nicht.
    Ich vermute es könnte an der FixID liegen.
    Der Empänger ist einfach nicht im Bindemodus.

    Und zum Flashproblem 5.0 weiß ich auch nicht weiter. Ich flashe jetzt noch mal die original und dann noch mal die 5.0
     
  20. Martinnw

    Martinnw Walkerafan

    Beiträge:
    24
    Zustimmungen:
    0
    Nein... brachte alles nichts.
    Er glaubt das er das Modul nicht hat.
    Vielleicht ist die Funke auch hin.
     
Die Seite wird geladen...